Username: Password:

Author Topic: v11.7.6 on raspberry pi  (Read 2869 times)

Offline dropkickflo

  • Trust: (0)
  • Rookie
  • *
  • Posts: 3
    • View Profile
v11.7.6 on raspberry pi
« on: December 09, 2018, 08:53:33 PM »
Hi guys, Trying to get this version of Gunbot working on my Raspberry Pi, but it's not working. Only the XT version is working on my PI. Anyone who knows to solve this? Any fix available?

Offline Aitor

  • Reseller
  • Trust: (+2)
  • Contributor
  • *****
  • Posts: 228
  • Gunbot.shop
    • View Profile
    • Gunbot.shop
  • Telegram: @AitorRuiz
Re: v11.7.6 on raspberry pi
« Reply #1 on: December 16, 2018, 02:15:14 AM »
Hi Dropkickflo, you are getting a message something like "To many redirects" or something like that, aren't you? If so, it's a bug for v11.7.6 ARM version. Better to use a previous version while v12 is released.

Offline dropkickflo

  • Trust: (0)
  • Rookie
  • *
  • Posts: 3
    • View Profile
Re: v11.7.6 on raspberry pi
« Reply #2 on: December 18, 2018, 06:46:58 AM »
There is no gui file, so i it isnt executable...

Offline Aitor

  • Reseller
  • Trust: (+2)
  • Contributor
  • *****
  • Posts: 228
  • Gunbot.shop
    • View Profile
    • Gunbot.shop
  • Telegram: @AitorRuiz
Re: v11.7.6 on raspberry pi
« Reply #3 on: December 23, 2018, 07:02:13 PM »
That's the way v11 works. I mean, now there is only one file. After executing it, you can access to GUI.

chmod +x gunthy-arm

./gunthy-arm

Access to localhost:5000 in your browser.

Offline SumEef260318

  • Trust: (0)
  • Rookie
  • *
  • Posts: 2
    • View Profile
Re: v11.7.6 on raspberry pi
« Reply #4 on: February 05, 2019, 04:15:59 AM »
Hi Dropkickflo, you are getting a message something like "To many redirects" or something like that, aren't you? If so, it's a bug for v11.7.6 ARM version. Better to use a previous version while v12 is released.

Hmmmm....
for v12 ARM, I'm still getting "To many redirects" in the browser when I tried to open http://localhost:5000
Anything else I need to set? like firewall? I'm new to raspberry pi too.

(PS: v12 is working fine on my Win 10; I just wanted to put it on a more dedicated computer, short of a VPS)

Offline Aitor

  • Reseller
  • Trust: (+2)
  • Contributor
  • *****
  • Posts: 228
  • Gunbot.shop
    • View Profile
    • Gunbot.shop
  • Telegram: @AitorRuiz
Re: v11.7.6 on raspberry pi
« Reply #5 on: February 05, 2019, 08:36:55 AM »
"Too many redirects" msg is a known issue for recent v12 ARM version. It was released yesterday night and we are working to fix it asap. 12v beta is working fine for ARM. Anyway, better to wait a bit. It will be fixed for v12 Final very soon, most likely in a few hours  ;)

Offline cmetom

  • Trust: (0)
  • Rookie
  • *
  • Posts: 2
    • View Profile
Re: v11.7.6 on raspberry pi
« Reply #6 on: February 13, 2019, 12:52:49 AM »
Is there any progress on this? I am getting the "Too many redirects" problem on ARM v12.8.1 build 998.

Thank you! :)

Offline Aitor

  • Reseller
  • Trust: (+2)
  • Contributor
  • *****
  • Posts: 228
  • Gunbot.shop
    • View Profile
    • Gunbot.shop
  • Telegram: @AitorRuiz
Re: v11.7.6 on raspberry pi
« Reply #7 on: February 14, 2019, 12:38:29 AM »
Dev team just told me they will push a fixed ARM v12 version tomorrow  8)

Offline cmetom

  • Trust: (0)
  • Rookie
  • *
  • Posts: 2
    • View Profile
Re: v11.7.6 on raspberry pi
« Reply #8 on: February 14, 2019, 08:43:17 PM »
Dev team just told me they will push a fixed ARM v12 version tomorrow  8)
Thank you for the update! That's great :)

Offline SumEef260318

  • Trust: (0)
  • Rookie
  • *
  • Posts: 2
    • View Profile
As per my subject title, the "too many redirects" issue on raspberry pi is back.

I put these 2 versions on my raspberry pi, and the older version works, but not the latest version.

It was FIXED in v12.8.3, but it is now BACK in v12.8.9.

It would be great if it can be fixed again. Thanks.

Offline sbogovac

  • Trust: (0)
  • Novice
  • *
  • Posts: 35
    • View Profile
Re: v11.7.6 on raspberry pi
« Reply #10 on: March 20, 2019, 10:49:37 AM »
Have you tried a clean set-up (so also an entirely clean/new Raspbian install)?

v12.8.9 works fine on my RasPi (2B!)...

Offline olliecrypto

  • Trust: (0)
  • Novice
  • *
  • Posts: 54
    • View Profile
    • TheCryptoBot Automated Cryptocurrency Bot
Re: v11.7.6 on raspberry pi
« Reply #11 on: March 23, 2019, 02:33:38 PM »
i had the same problem for a while, which was unfortunate as i preferred running my trading on the rasberry pi and then remote accessing it while traveling, so that if worse came to worse, and someone got access to it, i had no real data breach, but the newer arm versions didn't seem to run consistently and had a too many bugs for me to trust it with my btc.
i ended up just using older versions, but its been a while since i dug out my rasberry pi's, but the older versions definitely do work, so i'd try going thru the previous stable versions and see if anyone of those work for you.
My favorite Trading Tool :
Gunbot - the Automated Cryptocurrency Trading Bot
https://thecryptobot.com