Username: Password:

Author Topic: Illegal characters - can't start gunbot  (Read 3446 times)

Offline glinski

  • Trust: (0)
  • Rookie
  • *
  • Posts: 2
    • View Profile
Illegal characters - can't start gunbot
« on: March 12, 2019, 11:08:42 PM »
I'm getting this error:

 body: '{"code":-1100,"msg":"Illegal characters found in parameter \'symbol\'; legal range is \'^[A-Z0-9_]{1,20}$\'."}' } {}
Error: {}
    at errorHandler (C:\snapshot\Gunbotv12.8.3starter.3\ctx-wrapper.js:0:0)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)
Unable to connect to binance
Please if this error persists, stop Gunbot, wait a few minutes and then start it again...

Already tried to stop gunbot and wait, but the error keep going...


Any ideas ?

Offline Aitor

  • Global Moderator
  • Trust: (+2)
  • Junior Member
  • *****
  • Posts: 264
  • Gunbot.shop
    • View Profile
    • Gunbot.shop
  • Telegram: @AitorRuiz
Re: Illegal characters - can't start gunbot
« Reply #1 on: March 14, 2019, 02:20:52 AM »
It seems you put an invalid character in a parameter. For example:

Right one:

Gain: 4

Wrong one:

Gain: 4$

Check if you added any invalid extra character like ' " ( ) $ @ # . , etc...

Other option is just to do a fresh install and be sure you put proper values for all the parameters.

Offline olliecrypto

  • Trust: (0)
  • Novice
  • *
  • Posts: 55
    • View Profile
    • TheCryptoBot Automated Cryptocurrency Bot
Re: Illegal characters - can't start gunbot
« Reply #2 on: March 28, 2019, 01:43:23 AM »
i have had this issue when setting up gunbot late at night without coffee.
have you checked your entries for typos by chance?
My favorite Trading Tool :
Gunbot - the Automated Cryptocurrency Trading Bot
https://thecryptobot.com