Username: Password:

Author Topic: Running v3.2 on Raspberry Pi  (Read 737 times)

Offline ruphus

  • Trust: (0)
  • Novice
  • *
  • Posts: 37
    • View Profile
Running v3.2 on Raspberry Pi
« on: May 27, 2017, 10:03:55 AM »
Hey Guys,

can anyone help me setting up Gunbot on my Raspberry pi? Right now I am connecting through VNC to the Pi running raspbian.
Eventhough nodejs is not needed in v3.2 the newest nodejs is installed.

The tutorials i fount in this forum only cover v2.04. What are the main steps to get my bot running on my small Pi machine?

//edit:
When I try

chmod +x gunthy-armv7 gunthy-armv7x86
./gunthy-armv7(x86) BTC_ETH poloniex

it says "cannot execute binary - wrong file format..."


I am gladfull for any help!


Greetings
ruphus
« Last Edit: May 27, 2017, 10:54:40 AM by ruphus »

Offline criptonauta

  • Local Moderator
  • Trust: (+19)
  • Contributor
  • ****
  • Posts: 132
  • Escrow - Licenses - Consulting - Best reputation
    • View Profile
Re: Running v3.2 on Raspberry Pi
« Reply #1 on: May 28, 2017, 03:40:21 AM »
Hey Guys,

can anyone help me setting up Gunbot on my Raspberry pi? Right now I am connecting through VNC to the Pi running raspbian.
Eventhough nodejs is not needed in v3.2 the newest nodejs is installed.

The tutorials i fount in this forum only cover v2.04. What are the main steps to get my bot running on my small Pi machine?

//edit:
When I try

chmod +x gunthy-armv7 gunthy-armv7x86
./gunthy-armv7(x86) BTC_ETH poloniex

it says "cannot execute binary - wrong file format..."


I am gladfull for any help!


Greetings
ruphus

Isn't is a typo problem?

./gunthy-armv7x86 BTC_ETH poloniex
or
./gunthy-armv7 BTC_ETH poloniex

Gunbot licenses 10% off: 'Criptonauta_Gun' code. | Tuning, Custom Strats | No VPS? Get yours here

Offline AlfonseX

  • Trust: (0)
  • Contributor
  • **
  • Posts: 109
  • Trop de chefs, pas assez d'indiens !
    • View Profile
Re: Running v3.2 on Raspberry Pi
« Reply #2 on: May 28, 2017, 07:03:15 PM »
Hey Guys,

can anyone help me setting up Gunbot on my Raspberry pi? Right now I am connecting through VNC to the Pi running raspbian.
Eventhough nodejs is not needed in v3.2 the newest nodejs is installed.

The tutorials i fount in this forum only cover v2.04. What are the main steps to get my bot running on my small Pi machine?

//edit:
When I try

chmod +x gunthy-armv7 gunthy-armv7x86
./gunthy-armv7(x86) BTC_ETH poloniex

it says "cannot execute binary - wrong file format..."


I am gladfull for any help!


Greetings
ruphus

Isn't is a typo problem?

./gunthy-armv7x86 BTC_ETH poloniex
or
./gunthy-armv7 BTC_ETH poloniex

Or ./gunthy-armv6 ?
If you think I helped you, give me a drink:
in btc: 12aeQSpytxoehCEptQE8tUJVVSAS42LvXo
in eth: 0x02a611f0c15bccdb6fa8e5e4b0692ff6d77852bd

Offline ruphus

  • Trust: (0)
  • Novice
  • *
  • Posts: 37
    • View Profile
Re: Running v3.2 on Raspberry Pi
« Reply #3 on: May 29, 2017, 03:15:18 PM »
Code: [Select]
pi@pi:~ $ uname -a
Linux pi 4.9.28-v7+ #999 SMP Tue May 16 14:03:19 BST 2017 armv7l GNU/Linux

I guess it is armv7 since it is a pi3.

the error message indicates that the compiled script is not compiled for armv7, doesnt it?!

Offline ruphus

  • Trust: (0)
  • Novice
  • *
  • Posts: 37
    • View Profile
Re: Running v3.2 on Raspberry Pi
« Reply #4 on: May 30, 2017, 09:17:09 AM »
Has anyone any idea on how to get the armv7 version running on a raspberry pi 3?